Core updater

I'm totally newbie to retroarch but I tryed to run the "core updater" with no success.
Basically i would like to change the default Game Boy Advance emulator from meteor to vga m (or next) as meteor is quite slow.
Also tryed to "update core info files" but nothing changes. Any clues?
Thank you in advance!


  • Hi,
    The cores are updated by an system-update automatically. Else it you choose to update something, what before moving the pad again. It takes a few seconds for show the onscreen message and it seems to skip it if you move the pad again.

    Do you use retroarch or emualtionsstation?
    In the later you can define other emulators for systems as well. My favorite is mednafen.

    I have compiled new yabause and Uae4arm with JIT suppor which will be rolled out with the next or overnext update.

    There is more in the pipeline for the next update like AEROS. (

    Theoretically tomorrow!
  • Hi,
    I tought that emulationstation triggered retroarch cores by default (like amiga triggers fs-uae)...
    I don't know how to manage emulators in emulationstation (also tryed to edit the config file) so i tryed to update retroarch with no success (didn't touch gamepad anyway). Also ES isn't usable with the game pad as when i launch and select GBA it starts emulation in a window and then it goes again in ES menu, so i have to quit the ES menu to use the emulator. Then I press F1 for help because i need to configure gamepad controls to play (not playable by default) and as F12 command (to quit) does not work I have to switch again from fullscreen to window (alt+enter) when i want to quit the emulator. How I start in fullscreen mode? Is there a way to set default pad controls? Is there a way to change hotkeys within the emulator?
    I'm now running, but i'm still clueless about emulationstation, retroarch and emulation on indiego in general :(

    Thank you anyway!
  • Which pad do you use ? Psx or snes ?
    Are you running version 1.5.9 or older?
    For me gba emulation worked last time.

    Emulationstation config is "hidden" in Home/odroid/.emulationstatiion.

    I will check gba emulation perhaps something changed it again ?
  • In some emulators you need to press the tab key to configure controls.
    Sometimes you need to press the analog (red led) button on the pad to get it working.
    In emulationstation for example
  • Hi,
    I'm running 1.5.9 with PSX like controller. GBA emulation works but a bit slow so i opened "es_systems.cfg" and it reads "gba-xbmc %ROM%".
    Also all other emulators end with -xbmc ( i assume it stands for xbox media center) but I don't know which emulator are they actually using. Like amiga-xbmc is indeed fs-uae.
    Again retroarch core updater is broken :(
    Another problem is in Amiga emulation is when I press F12 (select+start on gamepad) I can only eject current adf but can't change with another. Also AGA emulation does not work. I have fs-uae launcher (and arcade) on on another debian notebook and it works well.
    Thanks again for your help!
  • I forgot to mention that also game scraping works only in emula but it doesn't work in emulationstation. I tryed several times.
  • Yes since 80% off all Amiga games were made for ecs it emulates ecs. FS-UAE.conf in you homefolder can be edited.

    I am sure i have replaced the gba emu with mednafen .. but perhaps I've didn't add this change to 1.5.9 so you need to wait for 1.6 which is around the corner. I will check in a minute if it should be in 1.5.9 on an clean unused console.

    Fs-uae is not intelligent. Everything like swapping adf's has to be edited in the config manually. To changes a game, you have to exit it in the menu on the bottom right (x)
    So you return to es where can choose another adf

    In the config file you can add up to 30 adf files for swapping when fs-uae is running but you need add them with a text editor.
  • edited January 2017

    nope I am right.. It was in an older update.

    "gba-xbmc %ROM%" was replaced already with "mednafen %ROM%" for all Gameboys

    It seems the update to 1.5.9 failed on your devices. Can you retry the upload and have an eye if it downloads "" at all ?

    If not.. download it from
    place it in /home/odroid/

    Than do a right click on the file and choose "extract here" -> Merge all -> Overwrite all

    Please try first the online update again if it fixed it.
    Medanfen is much better then the libretto things so I have replaced them.
Sign In or Register to comment.