retroarch will not load

Help. After updating to 1.5.8 my retroarch no longer works. In Emulationstation if I select a rom such as a Nes or PcEngine game the system goes to the desktop then returns directly to the rom list. Also if I go to the desktop, select applications, games, and then retroarch, nothing happens. Not even a change of the mouse curser to show something loading. What can I do? Is there a way to reinstall retroarch simply?

Please note. I am completely new to linux. I am having to crash course teach myself because of the indiego. (The more I learn though it does seem pretty awesome.) Treat me as if I know nothing. Maybe someone else is in a similar boat.


  • edited December 2016
    Can you please open a terminal and type "retroarch"

    If it crashes, it should print an error message in the terminal.

    Did nes and pcengine work before ? Or did you try them the first time after the update.
    Some libretto-core are useless (slow) and I am going to replace them with stand-alone versions of the emulators.

    Libretto-cores are updated independently when you trigger an online update. So if "they" (the libretto maintainers) change a core I can just react and change it : )

    What could cause it too is that the update wasn't complete. Just repeat the online update or type in terminal

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade

    If you see an error message, please report.
  • Ok, I tried retroarch in a terminal. Nothing happened. No errors reported. I then followed the command line instructions one at a time. Only the first command had a download and install. The others checked but said nothing updated, nothing installed. After I checked retroarch again through emulationstation, clicking through the application menu, and typing retroarch in terminal. Again all the same results. No retroarch.
  • Hmm
    Can you try the new update to 1.5.9 ?
  • Ok we can try to reinstall it for you..
    But I don't know why it happened for you at all..

    First do the update as usually from the menu : )

    Then after a reboot and when we are both hopefully at the same state..

    Go to terminal again and type
    sudo apt-get remove retroarch-odroid

    Then type
    sudo apt-get install --reinstall retroarch-odroid
  • Then it should work with "retroarch"
  • I'm sad to say still not working. Updated to 1.5.9 with no problems. Followed your instructions to remove and reinstalled. Everything worked fine. For reference nes and pcengine did work under 1.5.5. Also I looked and noticed under the /etc folder there is no retroarch.cfg file any longer.

    I have a good internet connection. Would it be possible to refresh the entire image and start over?
  • There where no update which affected anything.. curios.

    Did you edit something manually ? Perhaps there is now a typo in an cfg ?

    Which is under

    To prevent accidental manipulation they are hidden
    You can see them when you click ctrl+h in the file manager in your home folder (odroid folder)

    Or in the file manager menu if you set show hidden.

    Last try:
    sudo apt-get remove retroarch-cores-good
    sudo apt-get --reinstall retroarch-cores-good

    This reinstalls the retroarch cores.

    If it doesn't work .. try again the update to get the same retroarch config than me.

    Does emulationstation front end come up?
    I ask because it could be gpu related.
  • If this doesn't work, you can grab the image and write it to the sd-card.
    How, depends on the os you are using.
  • If you changed the menu driver in retroarch .cfg

    Please switch it back to rgui.
  • Video driver should be "gl"
  • Glad to say it is fixed. Not from reinstalling the cores though. That didn't work.

    Even though I never edited the retroarch.cfg file I decided to check it. In the folder I discovered back up copies of the cfg file. A little file renaming and it loaded the oldest copy of the file. Everything is fine now. Game on.
  • I am glad too : )
    If you add something useful to a config, please fell free to share it.
Sign In or Register to comment.