Successfully upgraded to Vanilla Forums v2.6. Please report any issue you may find.

Space exceeded and Comparing number with a string bug (win10)

edited March 2016 in AmiCloud
I am trying to use AmiCould with Windows10. As far as i know, i have the newest version. I started indiego, went to Amicloud and it said i had already donwlaoded it and opened the download folder instead from where i copied the package on top of the old files.

First thing i enoucntered was that when i logged in it reported quite short after an hollywood error "attempting to compare a number with a string" and closed amicloud.

After fiddling around a bit (i sort of recalled someone had reported bug like this and you had to do soemthing before logging in" i was able to log in succesfully. I had also destroyed all the contents from my AmiCloud folder before relogging in case problem was there (i had both files and folders in that folder).

After this, I added three files in my AmiCloud folder to be transferred to AmiCloud account, about 40 - 50 Mb each.

I see in AmiCloud a message where it says Transferring and tells me I have exceeded the space by some huge size number. I think it might have been as many as 11 numbers long: 12 345 678 901 bytes that it tells me that i have exceeded the space with.

However, when i check the list of stuff in AmiCloud (or at least i suppose thats what the button on left-bottom location does) it shoes no files in there at all (as there shouldnt be).

I am using Windows 10.

any solution for the problem, since right now i cant use it at all.

Tagged:

Comments

  • Hi @Bugala, thank you for your report.
    To let me help you I need some more informations, like for example the line number in the crash window (a screenshot could be really useful) since AmiCloud is a big app built on to of several modules I'm not able to track down the issue using you description.
    I'm using it on Window10 and it never crashed so it could be some special case I need to identify :smiley:

    Another thing you could do to let me help you is enabling the debug doing the following:
    - Open the folder where AmiCloud is
    - Open AppData
    - Open the file debug_acm.txt and change [SBL]debug = 0 to [SBL]debug = 1, this will enable the debug output.
    - Do the same for the file debug_amicloud.txt
    - On both files ensure that the flag [SBL]console is set to 0, this will enable the file log instead of showing the log in the console window.

    Now when you start AmiCloud it should generate two log files in the AmiCloud folder named:
    - debugacm_file.txt
    - debug_file.txt

    Try to reproduce the error/crash and submit these files to info@a-mc.biz since it may contain sensible data.
    Sorry for the issue!

    Fabio
  • Amicloud is currently running on background, and here are three texts that it keeps circling:
    "Contents Cynrhonized
    date"

    "Quota exeeded by 1 720 939 081 bytes
    file1.exe"

    "Quota exeeded by 1 721 268 856 bytes
    file2.exe"

    file1 and file2 naturally refer to the actual filenames.

    strange thing is, that it doesnt complain about the third .zip file at all, only those 2 .exe files, which are .exes made by hollywood compiler, but it doesnt have that third file in that remote list either.


    I will now turn that debug thing on and try to reproduce the errors. I was just putting these first in case they disappear after i turn it off.
  • Just sent you the log file, telling this here too in case someone else is having similar problem.

    I wasnt able to produce the crash bug, it didnt happen anymore. It might have had something to do with the files which i removed before being succefully able to log in, and those files dont exist anymore, as they were old versions of my programs, hence i saw no reason to save them.

    Because I uploaded them originally using older version of AmiCloud, crash bug could have had something to do with using old version first, and then at later point new version.


    However, the "Quota exceeded" bug is in those debugfiles clearly seeable.
  • I've got your mail, thank you!
    We are checking this problem, I hope to resolve the issue as soon as possible!
  • I've the same problem with Windows Vista.
    A file with a 1.6KB size and Amicloud tells me that quota is exceeded. (It tells me too that synchronisation is finished but nothing has been done on Amiga side)

    Will try to activate the debug too
  • edited February 2016
    Hi can you please retry? We have rolled out some new features and the technician made a small mistake..
    Everyone has become a Pro-User ... but the quota was set to 50MB...
    I have now set the quota for pro-accounts to 2500MB... But he must fix the problem on monday.
  • I started AmiCloud and logged in, but it still keeps circling those three messages of "contents synchronised" and two "quota exceeded by a lot bytes"
  • Hi can you please check the readme file in your archive if it says "::: CHANGELOG (BETA 04 - 10/12/2015)"
    This was the last version.
    If it says beta02 or 03 it will be an older version.

    Than please start Amicloud. Disable autologin. Close amicloud.. Restart AmiCloud and use the key button to login manually.

    Does it work now? If yes, go to options and enable auto-login again.
    For me it works on Win10...
    Could it be that you have a "hard" Firewall setting blocking amicloud or ACMmanager?
  • Another option. you can change your password here:
    www.indiego.rocks

    You could send me your login data so i can try it from my computer to see if something went wrong with your account.
  • readme reads "CHANGELOG (BETA04" and file dates of AmiCloud and ACManager are 10/12/2015.

    I have never used autologin, hence that is not the cause of problem, but have always used the key button to log in.

    Firewall asked for permission to use Amicloud and ACmanager both separately, which i granted, and it also today asked those permissions again (i suppose you did some change there), to which i again gave permissions, hence i would rather guess problem be somewhere elsewhere than firewall, but firewall is bit tricky thing, so who knows, maybe theres something there still. I just wonder why would it give that "quota exceeded" message, if it be a problem with firewall.

    I will change password and send it to you.

    by the way, you forgot to give email where to send that password. I know your email, but dont know if Tarzin knows.
  • Hi, can you please try with username: bugala instead of your email address?
    Meanwhile I will sit down to a win10 machine... argh : )
  • Ok... with your account I can't upload anything on win 10... strange I will check the OS X client with your account to find out if it is an os specific problem.. If not it is again the fault of the Server-programmer : )
  • edited February 2016
    hmmm... shame on us...
    @allanon
    It seems that the windows client is the problem.
    I can't upload anything as well on Win10 (with bugalas and mine account).. on OS X it is working.

    EDIT:
    downloading is working.. but uploading doesn't
  • Hi guys!
    I've reproduced the error on my machine, it was caused by the new (bigger) space available and a function with a wrong behaviour.
    Anyway I've fixed it and as soon as possible I will release a new build (maybe tomorrow).
    Sorry for the issue!
    :smile:
  • @Bugala and @Tarzin I have uploaded beta5 for Windows to the App Store.

    The changelog is as follows:

    ::: CHANGELOG (BETA 05 - 02/03/2016)
    - [FIX] Fixed a severe bug on Windows clients that was not allowing anymore to upload files after some changes on cloud server.
    This is the bug that was talking about Bugala and Tarzin, tested on Windows, all right now.

    - [FIX] Fixed a bug on Linux that was preventing the automatic execution of the ACManager helper program.
    If you remember there was the problem launching the ACManager because I was (wrongly) omitting the prefix ./ to execute the ACManager, now it works, I've tested it on Linux Mint 17 (VirtualBox).

    - [FIX] The client can be iconified/reduced to icon.
    Someone was complaining about the iconify gadget not present on the Amiga-like systems, in this build I've explicity set this gadget but on AROS it does not show, I suspect that if the window size is fixed (like for the AmiCloud main window) for some reason the iconify gadget disappear, i need to investigate further. Anyway the option to start the program iconified works, but once de-iconified it cannot be iconified back because of the missing gadget. If I cannot find a solution I will add a gadget in the interface to iconify the program. On linux & windows works without problems.

    - [NEW] Upload buffer and download buffer sizes can now be customized
    Since everyone have different Internet speed I've added the possibility to tweak the download and upload buffer sizes, it can be done from the preferences window.

    - [NEW] Polling interval can now be customized
    Again, from the preferences window the user can change the polling frequency. The default value is 20 seconds, There is no limit for the higher value so people can decide to check for updates every 30 minutes, for example, setting this value in seconds -> 30*60 = 1800 seconds. The lower limit is 5 seconds to do not poll to much our server, if needed I can raise this value.

    - [NEW] Monocore system-friendly mode can be used on single-core systems
    There is another option in the configuration window, setting this flag the file list elaboration is less CPU intensive because for every loop the program will friendly-wait for 3 milliseconds, this value is hardcoded but since I've no way to test it I need you to check if this work on AmigaOS4 :) On AROS there is no lag with or without this flag, but it's because the processor speed of my host machine.
  • Sorry for my late answer.
    Nice to see amiCloud working again with the latest update.
    Thanks for your work!
  • : ) You are welcome! Fabio is working on a new App Store client which will be more stable, show only compatible software to the host os and brings new functions.. In parallel the server API for Amicloud will be updated to utilize a messaging function and sub-folders.
Sign In or Register to comment.