Unable to play any ROMs except N64, HDD is a mess

I am running version 1.9.3 and EmulationStation is unable to start any games but N64's. It finds other ones, i can select them, it goes to the desktop then back to EmulationStation
I tried to use Retroarch but it is unable to add any content so I can only play those in the history menu (which i still don't understand how they come)
Emula console mode does not work (i just learned that I needed some credentials which I don't have)
I also tried to use the HDD to store ROMs but console crashes 50% of the time when I try to copy files onto it
So is anybody interested in buying my console ? Because it is useless to me and i'm very disappointed with it.
Unless somebody has any idea to fix my issues but anyway, the HDD is a mess, I did not get the right label nor the keyboard so I won't provide any with the console to whomever would be interested.


  • Hi,
    if it crashes.. it is likely that you accidently ran one of the HDD scripts(which shouldnt be done) in the settings or an update whent wrong.

    The best is to opten a terminal and do an update by hand. What is it saying? Any errors?

    sudo apt-get update

    sudo apt-get upgrade

    sudo reboot

    any errors?
    Password is odroid

    The hdd could just be faulty or the Powersupply isnt connected correctly. The HDD (red cable) must not be placed on the Odroid USB port but to the external PSU to get "extra" power.
    But when emulator crash it is more like a broken update.
  • For EmuLa have a look here

    Please update it before trying to activate your license!

Sign In or Register to comment.