Update 15th of October Version 1.9.1 "SeediGOhome, teamviewing is fun and time to give it a face"

Text with all changes and details will follow tomorrow... got a bit late today...

Update live now!!

Before updating:

Please check /home/odroid for a file called "updatearc.zip" . Delete it. Also in case you find "updatearc.zip.1" or "updatearc.zip.2" and so on.. the more often you tried updating in the past, the more of this numbered files will be there

They are results of a typo in an older update. I am sorry for this..
But as long "updatearc.zip" stays there, it will prevent downloading the new archive because wget (the downloader) will automatically rename the new archive while downloading. My fault...


Improved PSX direct CDROM support and performance:
- Compiled for CortexA8 using NEON
- Uses new OpenGL wrapper
- Raised CDROM read cache from 32 to 64
- Force PSX now finds the correct drive (in case the game is splitted in CDA and DATA track)
--> this is not the same emulator which is used by emulation station. (BIOS ROMS GO SOMEWHERE ELSE FOR IT - > REQUIRED FOR MAX COMPATIBILITY)
If you like to change settings like Joypad Layout /Controls, you need to add a keyboard and press ESC.
Under "controls" you can set the Joypad layout / Map your pad.
It should work out of the box with the delivered pads, but in case you use something else it may be required. Don't forget to save "globaly" .. The emulator has also an option to "save game dependent" settings.

Teamviewer access (got a problem? Need support? The easiest way is to access your system and solve the problem directly : ) ):

New Options in Settings:
- Install Teamviewer -> installs Teamviewer

-Run Teamviewer -> runs it -> tell us your User ID and shown PIN-code, so we can access your console remotely to give support (not 24/7 of course)

- Update i386 subsystem -> updates the i386 components -> For example ca-certificates which prevented Spotify from working when they are outdated.


- Main Menu has been updated by Fabio and includes many improvements. The first visible one is the theme support.
-> Press t = theme on a keyboard and choose another one to switch it.
Hava a look at /home/odroid/FSLauncher/FSL/themes to modify exiting ones and learn how to arrange item and more.
I would be glad if we can add soon some user created themes.

Another big improvement is the possibility to change resolution on the fly to improve emulation speed and than revert back to normal.

As requested I have added the old way "prio Version 1.5.9" to preload AmigaCD32 games.
It is faster but not as accurate than the other way. If it works, it works : ) So feel free to use it instead of the "bullet proof but slow" option.


  • edited October 2017
    Nice, thanks for the new update. But where do those ROMS go then? :)
  • edited October 2017
    : ) Will post it tomorrow.. Need a bit sleep.. not 100% sure but I assume to /home/.pcsx (it is a hidden folder)
    With ctrl+H you can make hidden files visible.
  • Is it online yet? :)
  • Nope, ~8 hours left.. will Post a go here when it is in place.
  • but updaterzip 3-4 is still going to be there?
  • Nope.. you can delete it too.
  • Is it up yet? :P You said around 8 hours almost 20 hours ago. I'm just anxious to test it. :D
  • edited October 2017
    A few minutes... we bumped it to 1.9.1 ..
    2 minutes...
  • Now PS1-discs don't work at all.
    They at least started before this update, even though they were unplayable. But now, after the update, they will not even start.
    Is there something eff'ed up with my blu-ray drive?
  • PCSX does not seem to find my Bios-files. I have put them in the hidden .pcsx-folder. Do I need to rename them?
  • kodi dont work enymore. it take make me to desktop mode.
    Teamviwer don work to instal
    update 1386 subsystem dont work.
    what is corect rom permission?

  • I can also confirm that Kodi does not work. For an update that was supposed to fix most of the problems... it seems it has broken more than it's fixed. :(
  • edited October 2017
    My sega, nintendo, pc engien. atari jaguar are gone in emulatorstation
    the roms are in the map on my hdd but emulator station cant find em enymore..the emulator dont show up att all in emulatorstation
  • I have just updated, both PS1 and CD32 emulation seem to work much better now from disc, with a few glitches here and there, so still not perfect (I have the PS BIOS copied to the .pcsx folder).
  • edited October 2017
    emulator station sems to look for the roms in bookmarks home ondroid roms . Insted of devices media odriod.
    The last one is my hdd
    enyone now how to fix this?
    Or have the same problem?

  • edited October 2017
    I assume for some reason that one or two packages haven't been updated on your side.

    everyone with a problem.
    Can you please press ctrl+alt+t ?
    This will open a terminal.

    sudo apt-get update

    Any errors? then type:

    sudo apt-get upgrade

    answer with yes whenever you are asked.
    Any errors?

    Then type
    sudo apt-get dist-upgrade
    Answer everytime with yes

    Any errors?

    If there are no errors, it should work.

    Plan B:
    Use the new "install Teamviewer option" *
    Then we can arrange a date were I can access your console and try to find out what is wrong.

    *You will need to activate Exagear (for which you can request exactly 1 free key from me). The keyfile has to be placed to /opt/exagear/lic

    than you need to run in a terminal:
    sudo /opt/exagear/bin/actool This will active it and from that point you can run any i386 linux binary with "exager".

    What could differ is that some use an HDD and some not. But theoretically it shouldn't matter.

    It is more likely that one package was broken and now block other system parts from being updated.

    Try to open the DVD-RW again and close it. Wait a little for the LED to stop blinking.

    Mine uses a BD-RW but has no HDD.
  • New codename of the update is "facepalm" :blush:

    What could it be easy..
    If one is interested we can have a small team viewer session from 20:00 german time tomorrow.
  • edited October 2017
    done no erros and nowere to write yes . Sill dont work. Cant install Teamviewer beuce it dont work.
    and cant play game roms from my hdd becus it try to read it from the sd card i belive.
  • If i put roms in the bookmark map emustation find the rom whitout problem..
    but i think that is my sd card and not my hdd
  • edited October 2017
    I cant be on Team viwer but i can be here on this forum 20.00 tomorow if u have time.
  • edited October 2017
    Iam here
  • As messaged privately:

    Teamviewer requires an Exagear keyfile. You can request one from me.

    The best is to place it on an USB-stick or SD-card

    Press ctrl+alt+t to open a Terminal
    than type:
    sudo pcmanfm

    Password: odroid

    This will open the file manager with root privileges, so you can copy and paste the keyfile to /opt/exagear/lic
    Unzip it

    Than type in terminal (close the file manager):
    sudo /opt/exagear/bin/actool

    A message should say that exagear has been activated
  • Ok I have accessed Andreas console via Teamviewer and found out some failures.
    Appstore works by the way ;)
    But I've forgot to add a new file regarding Kodi.
    My intention was to get you back to the console menu when closing Kodi..
    I will add this script in the next update (tomorrow evening)
  • Problem solved whith Teamviewer and Pascal.
    its a grate tool =) Tanks for you superb healp =)
  • 1.9.1a is underway. Should be ready tomorrow morning
  • Should work now.
  • hmm.. a server maintenance is causing file corruption on downloads...
    Please try at a later point again.
  • 1.9.1B is now online
Sign In or Register to comment.