Successfully upgraded to Vanilla Forums v2.6. Please report any issue you may find.

Getting games to run, and then run well

Hi all!

Only semi-tech-savvy here, so please bear with me. The big draw of the IndieGO for us was the potential ability to approach CD-based games like the Retron5. We were so so so pumped when it arrived this past weekend! :smile: We're trying to use physical games instead of isos or bin/cues, and want to ideally be able to pop in any game and have it run no matter the system.

Now, when we put in a game, it has a lot of trouble actually starting.

We did manage to get FF9 started, but holy crap the sound was stuttering like crazy and after a couple minutes the video followed. RE2 wouldn't load past the explicit content warning, with zero sound. Both of these were tested with both force-PSX-CD options. Then I updated the console from 1.8.0 to 1.8.4, and nothing will start. D:

Preloading CD rom option: Says "cannot remove 'home/odroid/ROMS/PSX/preload.bin': no such file or directory". It does the same thing for preload.cue and preload.toc. It apparently checks a few other things, then repeats "WARNING: Unit not ready, still trying..." several times before quitting itself. :disappointed: Screenshot included below!

Amiga games, when used with the force cd32 option, will load to the Amiga's version of "please insert floppy disk." It doesn't seem to register that there is a game in there.

To test that the /roms folder was working, I did download a couple dreamcast games and put them in the appropriate folder before launching EmulationStation. Those work GREAT so far! So I'm happy that the emulation is working and definitely plan to research hacks and homebrews, and if all else fails (or isn't ready yet on the software side) then I can just download all the appropriate games I've got then emulate them. If it's possible to get the physical CDs working it would be awesome, though!

Something else I discovered: if you try to boot up the system with the included USB PS-style controller plugged into the leftmost USB port, it'll refuse to boot up until it's removed. I put the dongle for the keyboard/mouse in Port 1 and the controller in port 2 instead, and it loaded up just fine. Don't know what was up with that, lol!

Thanks guys! :)

Comments

  • Are there anybody who actually managed to run any CD32 games from disc yet? I tried a number of them, originals and backups, but none of them worked. I always end up on the Kickstart 3.1 screen with the CD not booted.
  • Same thing here when I tried a couple. pascal announced version 2.0 around the first of July and said it's close to release. Will probably have to wait and see what happens after that.
  • Please check the latest update.
    It includes fixed Amiga Emulators and I hope close to 100% CD32 compatibility
  • edited October 2017
    I must be doing something wrong, but when I select Force CD32 from the boot menu (1.9.1), it always loads the CD previously grabbed and not the one in the drive. What should I do to make it load the one in the drive?
  • hmm... could be my fault. Could be that it takes the permission from the CDROM which is only "read" and when you try the next game it can't replace the other because it is write protected.. hmpf.. Will do a hot fix on this tomorrow.
Sign In or Register to comment.