Successfully upgraded to Vanilla Forums v2.6. Please report any issue you may find.

Project Lila Beta and Jim Power low fps (fs-uae?)

Tried Project Lila Beta and Jim Power using the menu options and both run very slow (4 - 5 fps or less).

Odroid XU4

Comments

  • Same here - optimizing is the next big thing after finish the delivering
  • Hi guys,
    I've not yet updated the IndieGO! to the latest version, I'm on the previous one, but here Jim Power started from the the "Kickstarter Goodies" menu runs very smoothly.
    Project Lila Beta is a bit laggy.

    I'm updating to the latest version so I can campare how they performs after the update.
  • I confirm that the problem is on the latest update, after updating the IndieGO! Jim Power started to run very slow, @Phoenixkonsole : can you chck what's changed with FS-UAE?
  • Seems that the GL acceleration is gone...

    UAE: Initializing core derived from WinUAE 3300b2 LOG: /home/odroid/Documents/FS-UAE/Cache/Logs/fs-uae.log.txt libGL error: MESA-LOADER: malformed or no PCI ID libGL error: unable to load driver: exynos_dri.so libGL error: driver pointer missing libGL error: failed to load driver: exynos
  • That would do it, is it then a problem for all emulators? Or only fs-uae?
  • I think that the update has put the wrong FS-UAE build on the IndieGO! because it should use OpenGL ES and not OpenGL, but I could be wrong since I'm not a Linux expert.
    @Phoenixkonsole (aka Pascal) should know what happened, let's wait for him for some clarifications...
  • Update is coming..
    The previous FS-UAE was old but compiled for OpenGL ES ..
    The new one is based on mainstream FS-UAE but requires full OpenGL ...
    I have found a way to wrap the OpenGL calls to OpenGL ES.
    In 10 minutes it should be up.
    The good news... we can hope for AmigaOS 4 support : )
  • I'll try it out tonight after I reopened the case to turn on the odroid again ; ) It is currently very easy to turn it off on the software level. Thanks for the update!
  • MarkB said:

    I'll try it out tonight after I reopened the case to turn on the odroid again ; ) It is currently very easy to turn it off on the software level.

    Hi @MarkB, can you explain about that? :smile:
  • If you start xbmc and mistakenly choose to power off the system in the close menu (I chose to close the application but the menu changed during the mouseclick and activated the power off action) then the console will not power on by plugging it into the power outlet, it will only turn on if you open the case and press the hardware power button located on the odroid. The same happens if you double click the power off icon in the desktop environment but I do not recall (am at work so cannot check at the moment) where it was located (power off and reboot icon next to each other).
  • Ok! Thank you for the tip :smiley:
  • The new update did not fix the problem unfortunately, it added maybe 1 or 2 fps.
  • Yep.. I have fixed it within the last 3 hours... I could take a hammer and punch someone...
    The problem ist that the maintainer of the odroid packages messed up all my configs but didn't check his own packages as well.. so in the moment a lot is just "not" working.. I am working on it.
    Amiga is done.. I will add 3 entries to EmulationStation. (A500 / A1200 / CD32).
    Tomorrow.. All this hits my road map and Version scheme.. so tomorrow I will release 1.8.1 (New AMiCloud, new Appstore and several fixes)
Sign In or Register to comment.