Bluetooth keyboard

Hi everyone. Got a Rii I8+ bluetooth keyboad to use with my Indie Go Console but can't get this working.
I disabled sixad from main menu (I really need to do this at every startup?) and also succesfully paired the keybord but neither the trackpad or the keyboard are working. When I go in "Bluetooth devices" and hit setup it says: "Device added successfully, but failed to connect". Same thing if I hit "connect" it gives me input error.
Other weird thing is that the first time I paired it few buttons worked but only numbers and some symbols. Also when I open the bluetooth devices the system eventually hangs in a black screen!
Any help would be appreciated!

Comments

  • Hi, the rii8 should come with an own Bluetooth dongle.. are you using this or the one provided in the white paperboard box (there is a dongle too from odroid xu4 inside).
    I can check it after work this evening.

    The deactivation of sixad is only required once. But I will check too if there is something wrong.
  • I'm using the dongle provided with the odroid console. Later I'll try with the rii8 dongle, hopefully it works. Cheers
  • Depending on the revision of the rii8 it is not Bluetooth but 2.4ghz so it may be indeed required to use the rii8 adapter. Still at work here
  • Hi mate,
    i did a test.. it is no bluetooth keyboard but a "prorpeatary" wireless connection. You need to connect the Rii8 receiver : )
    Nothing to setup.. It will just work.

    Well.. z is y in europe but you can change it with the locale setting.
  • I will try. There are two different rii8 models, one wireless and one bluetooth. I got the bluetooth model but again I will try later using its own dongle. Finger crossed :smile:
  • Unfortunately it didn't work :(
    First thing first I've to always disable the sixad as it (i suppose) starts the bluetooth service, otherwise I get this message: bluez daemon is not running, blueman-manager cannot continue (and so on).
    With the rii8 dongle it doesn't even pair because it asks for a number to pair that I can't obviously input (also tryed with another spare bluetooth dongle).
    With the odroid dongle it pairs but don't connect...
    Got only once connected and the trackpad don't work and the keyboard only inputs numericals and symbols (with wrong inputs).
    I also tryed changing keybord type and layout in the keyboard settings.
    Assuming I can't get the rii working on odroid console (works like a charm on windows), can anybody suggest me a sure working wireless keyboard plus trackpad solution?
    Thanks in advance!
  • can you give me the model number of the rii?
    I can check if I have the corresponding version here.

    I tried the expensive led backlit version with the 2.4ghz receiver = plug and play (also multimedia keys work)

    an idea which could at least help you regarding sixad :
    There are two options in settings

    1) disable sixad (PS3)
    Which disables it for one time

    And a bit more below
    2) disable PS3 pad support at boot

    Which will kill it as long you don't choose to enable it again

    In the meanwhile I will use google to find out what makes the Bluetooth version of rii8 special (regarding configuration)
  • edited December 2016
    Hi again,
    I have found others on the net with the same trouble.

    First disable sixad completely as mentioned above.

    Than if you sync it and the message about the number to pair appears:

    I have read you need to choose something like 0000

    And type this on the rii keyboard as well.. this will pair the device.

    You can follow this steps from number 9) i found on the net:

    ------------copied form this thread
    https://www.raspberrypi.org/forums/viewtopic.php?t=18543
    ------------------------------------------

    9. launched Blueman from Menu>Preferences>Bluetooth manager
    10. Press the BT button on Rii keyboard (flashing light)
    11. Scan for keyboard (should show Micro Keyboard)
    12. Highlight the Micro Keyboard and press Setup
    13. Select Use Custom Passkey and put whatever you like (i used 0000) then forward
    14. type the Passkey you used (0000) and press enter on Rii keyboard
    15. Select input Service on next window
    16. rebooted the Pi
    17. the Rii won't be working just yet so still using normal keyboard, log in and launch LXDE
    18. after first reboot a notification about "BT Authentication" will come up (i selected always accept)
    19 Your all done :geek:

    If you follow all these steps (too many....... lol) that will be the Rii BT keyboard now working from command prompt on boot and in LXDE

    anyone else thinking of getting one.....
    The 2.4 Ghz is 100 times easier to set-up as its just Plug in and Play.

    But where is the challenge in that :P

    ---------------------------------------------------------------
    End of quote


    The good thing is if you manager it, it will work : )
  • Hi, with the rii dongle the problem with pairing is that I can't input 0000 or any other passkey as long the rii is not responding (points 13 and 14). I can input it with a normal keyboard but again the rii is not responding (sorry i was not able to upload the photos). With the console dongle I managed to make it kinda work only like a numeric pad as it don't ask for a passkey to pair.
    My rii model number is RT-MWK08+, and by the way, disabling ps3 at boot don't do the trick as the bluetooth service only start disabling sixad.
    I'm considering to buy the wireless model (or something like that) but I must be sure it work with the odroid console. Thank you anyway for helping me! Cheers
  • The ones I offered with the consoles are the 2.4GHZ models.. So they work definitely.

    13./14 require to have a normal usb keyboard attached as well. See also 17) where he wrote that he still uses the normal Keyboard at this point.

    I need to check if the setting to disable BT is buggy.
  • Yep I can verify that sixad PS3 driver is still blocking BT after a reboot.. Hmm..
    I need to dig deeper why.
  • I have fixt it
    I had to "uninstall sixad" and "reinstall bluetooth" to revert to "normal" working bluetooth.
    PS3 pad support is made by the devil : )
  • Update will be made available in some hours
  • After all I got the 2.4ghz model and i confirm it's working fine. Anyway i can't input F12 even with the "fn" button pressed, causing problem within emulationstation. Getting used to es and emula although it asks a licence key (?) to achieve some functions. GBA emulation is a little slow as it skips frames (can't figure which emulator is it using). Also wireless connection breaks up a lot maybe cause some interference with rii8 running at same band length (2.4 ghz), that's why i choose bluetooth model... Got the update, thank for your support!
  • Hi,
    Yes I noticed this too yesterday with the 2.4 ghz model.
    if am directly in front of the console (close to the tv). Your can power off the keyboard once and than power on again if you notice this.
    If I use it from my couch which is further way it is ok and causes only a slow down of wifi. When I close it (power off slicker on the keyboard) it goes fullspeed again.
Sign In or Register to comment.